Welcome to SSA Car Audio Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

Community Reputation

-1 A few mistakes

1 Follower

About hdorre

  • Rank

Profile Information

  • Gender Male
  • Location NY
  1. Yes.. With Nick gone, CS is lacking even more.
  2. What part of Connecticut are you in? I live in Brewster, NY.
  3. I have a Viper 5701. I love how it has 2 way. I have 2 piezo sirens and the motion sensor. It's soo nice. I just have to wire in the remote start.
  4. Stingers going out isnt uncommon. Ive heard a lot of people talking about Dakota Digital Voltage gauges. Theyre more expensive, but Ive read time and time again that theyre more reliable. Im most likely going to pick one up. I really want a T2.5kbdCp.. theyre just soo damn expensive lol
  5. Ooh yes, it certainly is progress! How bad is the drop?
  6. All that from a 5k and 2 12s? Very nice!
  7. Psh, age is only a number
  8. Scroll all the way down. http://damoreengineering.com/dd1.html Its a .rar file. I recommend the program "WinRar" to extract the file.
  9. Yeah, Ive tried that too. I honesty think that the problem is the trimmer. Maybe buying a new probe will fix the problem? Thanks for the help.
  10. I flipped the "x10" switch on the probe, and pressed the "x10" button on the scope. Yeah, Ive tried that many times. I actually just tried it again; just to double check. Y-Position doesnt seem to do the trick either.
  11. No, but I emailed Velleman about it. If they dont give me the help I need, then ill update this thread. Thanks!