Jump to content

Search the Community

Showing results for tags 'DG 61'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • SSA® Store
    • SSA® Store
  • Announcements, Events, and New Member Sign In
    • Newbie Sign IN
    • News, Announcements, and Lobby
    • Competitions & Other Organized SPL/SQ Events
  • Main Sections
    • General Audio
    • Amplifiers / Head Units / Processors / Electrical
    • Subwoofers / Speakers
    • SPL & SQ / Fabrication
    • Sound Deadening
    • Build Logs
    • Home Audio
    • Classifieds Feedback
  • Show Off
    • Videos
    • Photography
  • Technical Reference Center
    • Advanced Discussion
    • Technical Info & How To's
    • Product Reviews
  • Manufacturer's
    • Adire Audio
    • Ampere Audio
    • Audio Nirvana
    • Crescendo Audio
    • Incriminator Audio
    • Khaotik Enclosures
    • Mechman High Output Alternators
    • Second Skin Audio
    • Sound Solutions Audio (SSA®)
    • Synergy Audio
    • US Acoustics
    • XS Power
    • Manufacturer Archive
    • Your Section Here!
  • Other Audio resources
    • 1800WOOFERS.com
    • LaFountain Design
    • Resources Archive
  • Team Sections
    • Team Decent
    • Team IAK
    • Team SSA
    • Your Section Here!
  • Classifieds
    • For Sale/Wanted
  • Automotive & Performance
    • Automotive and Performance
  • Off Topic
    • Off Topic
    • Vapors Lounge
    • Hall Of Fitness
    • Computers / Electronics / Music / Games

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Real Name


Location


Interests


Vehicle

Found 1 result

  1. I installed a audiopipe 1500 to power a sundown x10 in a ported box. jl audio componants in the front doors jl coaxials in the rear deck running on a jl700/5 the 2012 mustang gt factory hu and lastly the pain in my back is a audiocontrol dq 61. I mounted everything on a wall behind the rear seats just in the trunk. I 2 separate stinger 1/0 for power as well as grounds. My signal is also stinger 9 conductor w/ 2 350amp fuses. the 5th channel on the 700/5 is waiting on jl8w3 mounted in the front doors. I hope there is something my eyes are not catching because the insides sound like tin cans. when I am able to improve the sound I cant turn them up beyond 25% without clipping. I had the factory shaker 500 which is factory amps 50w to power the factory 8" subs in th4 front doors. they are DVC so I pulled the low signal to use for my dx10. No issues with the 10" in the trunk. the front doors also have 5x7 with center tweets. I am pretty sure the signal is all highs since that is the reproduction when used as the main signal in to the DQ61. So im summing the front and rear 2 channels and after entire weekends and evenings twieking it I still have yet to find the sweet spot of even tolerable to play loud. My goal is loud and clear. I mostly listen to rock, alternative so I gotta get this straightened out. Lastly Im stubborn about completing this on my own but finally took it to car toys, which have yet to disappoint me. Paid 85 bucks for an hour of an installers time and he gave up as well. are the DQ61s audiocontrols stepchild or is it me.
×