Jump to content

Search the Community

Showing results for tags 'Warranty'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • SSA® Store
    • SSA® Store
  • Announcements, Events, and New Member Sign In
    • Newbie Sign IN
    • News, Announcements, and Lobby
    • Competitions & Other Organized SPL/SQ Events
  • Main Sections
    • General Audio
    • Amplifiers / Head Units / Processors / Electrical
    • Subwoofers / Speakers
    • SPL & SQ / Fabrication
    • Sound Deadening
    • Build Logs
    • Home Audio
    • Classifieds Feedback
  • Show Off
    • Videos
    • Photography
  • Technical Reference Center
    • Advanced Discussion
    • Technical Info & How To's
    • Product Reviews
  • Manufacturer's
    • Adire Audio
    • Ampere Audio
    • Crescendo Audio
    • Incriminator Audio
    • Khaotik Enclosures
    • Mechman High Output Alternators
    • Second Skin Audio
    • SoundQubed
    • Sound Solutions Audio (SSA®)
    • Synergy Audio
    • US Acoustics
    • Wolfram Audio
    • XS Power
    • Manufacturer Archive
    • Your Section Here!
  • Custom Fabricators / Youtube
    • caraudio911.com
    • 1800WOOFERS.com
    • LaFountain Design
    • Fabricator Archive
  • Team Sections
    • Team Decent
    • Team IAK
    • Team SSA
    • Your Section Here!
  • Classifieds
    • For Sale/Wanted
  • Automotive & Performance
    • Automotive and Performance
  • Off Topic
    • Off Topic
    • Vapors Lounge
    • Hall Of Fitness
    • Computers / Electronics / Music / Games

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Real Name


Location


Interests


Vehicle

Found 4 results

  1. TJ Fields

    Shipping back to Fi

    There is a problem with my Q 12, and I need to send it back to Fi to work on it. I got an email from Nick that says: "The only thing I can think that may have happened is the coating that is on the top side of the cone body has delaminated. One out of every 1500 cones or so will run into this issue. Print this email off, place it in the box and send it in to us. When we get it back in I'll check it out or another tech will check it out and see what's going on." So do I not need a return authorization number? I just send the box with the email in it and that's it? Also, does it matter how I ship it? Is USPS fine?
  2. TZwiers

    Blown SP415

    I bought my SP415 dual 2 ohm back in October and received it in November and after only 5 months of use, the foam surround is ripped. I can't seem to figure out how this could have happened so any input would be great. Also curious if this is covered by FI's warranty. But here's the setup: -1999 Grand Prix GT Sedan -FI SP415 dual 2 ohm wired to 1 ohm. No spaced spider and no cooling (daily use, didn't see the need) -AQ2200d tuned to 2100 watts RMS using a multimeter -DIYMA oversized 0awg CCA power (appx. 22') and ground (3') with a 200 amp circuit breaker near the battery -Optima Yellow Top -Ohio Generators HO Alt (its an older model but I had them test it and it puts out a minimum of 165 amps and max of 234 amps, and with a smaller pulley it idles at about 200 amps) -Box is appx 4.02 usable cubic feet (after displacement) with sub mounted up and 6" Aeroport entering the cabin -Polk PA660 powering (2) 5.25 Alpine Type S and (2) 6x9 Alpine Type S The electrical is all solid and nothing was rubbing on the sub so how could this happen? The only thing that I could think of is if there were some goofy pressures in the box that were created..but any help is much appreciated.
  3. So I installed my new 12" xcon last week and I could not get it to seal up against the baffle. Tried 3 times. Upon taking off the gasket i found the gasket had a tear in the seam and after really looking it over I found the basket is warped/bent in the upper right side. I can't seem to find any sort of tech support for SSA, but I don't wanna try to fix it myself unless I know I can't get it fixed under warranty. Any help is greatly appreciated!
  4. Hondabiker95

    **Is this under warranty?**

    Ok so today my dual 1 SSD 18 stopped working for seemingly no reason during very low volume music. The sub is not frozen. I checked the sub with a battery and it did nothing, checked all wires etc. etc. I will check the coils on my multimeter when I get to work tomorrow. The box is build to the specs of the sub 7cu.ft. @ 32hz. Powered with a Fosgate t1500-bd (2ohms and very conservative gain). The coils look normal to me, not black or even dark in any way. Sub doesn't and never did smell like burnt coils. I'm thinking the coil's glue failed. I'm stumped on this really as I've been good to this sub and only had it for a few months. I hope Fi will take care of me and warrant the sub. Also if this is under warranty, do you guys know if shipping would be covered?
×