Jump to content
Cant Get Enough

can i get an alt?

Recommended Posts

I have a batt bank, 2 hc2400's and a hc1800

Bought a 200 amp power bastard alt that is a direct fit for my 02 taurus

It spiked to 16+ volts when i hit the gas lights got real bright then the voltage regulator

kicked in and it settled back to 14.5 v. Sent ot back they put in a new regulator

same problem. Bought a HO rebuild kit for my stock alt, same problem. Went to

a local mechanic and he said there is no way to solve the slow regulator issue

I'll buy a mechman if they can solve this issue. I also need a direct fit due to space restraints

Why is my HO alt having these issues.

Share this post


Link to post
Share on other sites

Possibly a bad battery. Sounds like the most likely answer. Big 3 upgrades done? Do you have proper grounding and wire size?

Edited by BrutalBasser

Share this post


Link to post
Share on other sites

Big three - yes

Doesn't do it with stock alt

My batts stay for days above 12.76v and 13 to 14.4v with car running

With stock

Share this post


Link to post
Share on other sites

I would try testing each battery individually out of the car after resting for at least two hours. If one of them is going bad, it will eventually ruin all of the others in time. This will also cause charging spikes like you are having, and burnt out regulators. 

Share this post


Link to post
Share on other sites

Already tested individually. Is it possible to disconnect batts and run off

alt and see if it surges. I mean if I can do it on stock alt why not the HO alt

Share this post


Link to post
Share on other sites

The H.O. puts out more current than your stock alternator. This creates more heat inside of your batteries, and if cells are going bad, you get these issues as described.

Share this post


Link to post
Share on other sites

Lets say I go buy a car batt tomorrow the biggest I can get. That should stop

The voltage spikes. If that doesn't work any other ideas

Share this post


Link to post
Share on other sites

What is your current front battery? Is it AGM?

Share this post


Link to post
Share on other sites

Disconnect the 2400's and test the 1800 under a load. Do you currently have your HO alt in?

Share this post


Link to post
Share on other sites

I changed it out tonight but the messed up part is I've swapped out my alt so many times

I can do it in fifteen mins I'll change it back to the HO tomorrow and try each batt seperately.

I originally started with the hc1800 and the ho alt got pissed put the stock back in and then added the hc 2400's to solve dimming issues. But the ho alt really makes the bass

hit, thats why I want it to work so bad. I,ve only recently decided to put the ho back in when

I read a batt bank is required with ho alt.

Share this post


Link to post
Share on other sites

I also checked my batts when they were new and the autozone guy said they all

were bad didn't pass cca test. But I heard cca's are low on kenetiks and should

measure using ah

Share this post


Link to post
Share on other sites

I am almost certain you have a bad battery. I have had experience with this same issue.

Share this post


Link to post
Share on other sites

Just ordered a couple new hc2400's and bought a cranking batt also ordered

a motocraft voltage regulator and gonna swap out that crappy aftermarket

regulator then see how it goes I'll update after the alt install

Share this post


Link to post
Share on other sites

I have heard bad things

and had a bad experience

with powerbastards 200-220amp alts

especially the universal fit ones

Share this post


Link to post
Share on other sites

It's actually direct fit alt,not universal and I changed the regulator when I first got the

alt since I was getting voltage spikes and the one I ordered to replaced it was exactly the same brand and model that came with the HO alt but I didn't know

until I opened the alt up. I also bought a HO rebuild kit from a different site for my old burnt up stock alt and that even came with the exact brand regulator with the exact same voltage spike issue. So with the new batts and oem regulator I hope it will

solve my dilemma. This will be my last attempt with a HO alt or it'll be batt bank and stock alt.

Share this post


Link to post
Share on other sites

I had the same problem with my alt from mechman it is a direct fit. My head lights would get bright as I gave gas plus air bag light would blink on and off until My headlights burnt out on freeway. So I stuck my stock one in and had no problem. Contacted mechman sent out alt on Friday by thurs of following week already shipped back said it was a faulty regulator installed back in and bought a cheap tempory batt from Walmart so far so good. Great service from mechman

Share this post


Link to post
Share on other sites

mechman is great, love my mechman, 

 

 funny story, over the weekend at a usaci meet, after my street beat run, ( music for 30 seconds score averaged )every one came up to me.. what kinda alt do you have man, where did you get it it on and on...

 

 see, every one else starts high at the beginning (good voltage and reserve ) but they quickly start falling in Db's   .... when i ran, i started at 149.0 db and ended at 150.2!  something you never seen in the lane. but  i never fall like most the guys do, and i dont even have very much battery reserve    mechman 6 phase technology !!

Share this post


Link to post
Share on other sites

mechman is great, love my mechman, 

 

 funny story, over the weekend at a usaci meet, after my street beat run, ( music for 30 seconds score averaged )every one came up to me.. what kinda alt do you have man, where did you get it it on and on...

 

 see, every one else starts high at the beginning (good voltage and reserve ) but they quickly start falling in Db's   .... when i ran, i started at 149.0 db and ended at 150.2!  something you never seen in the lane. but  i never fall like most the guys do, and i dont even have very much battery reserve    mechman 6 phase technology !!

I love my Mechman too. I hardly ever have voltage issues and my amps love the power.

Share this post


Link to post
Share on other sites

DC has had this technology for years..  but it's hard to convince those who've seen their performance in the past do business with them now.

Share this post


Link to post
Share on other sites

DC has had this technology for years..  but it's hard to convince those who've seen their performance in the past do business with them now.

That's a shame too. I inquired about an alternator from them, and I never got a single response out of five emails over a two month period.

Share this post


Link to post
Share on other sites

I ordered mine around this time last year.  Got it powder coated, all specs understood via phone and ETA was right on the dot throughout the process.

 

At the time i ordered, it wasn't ready but now it may be. 

 

There checkout system is setup to give you up to the minute progress information far more detailed than what'd you see on a tracking number for example with the progress of the alternator build.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Who's Online   0 Members, 0 Anonymous, 29 Guests (See full list)

    There are no registered users currently online

  • Recently Browsing

    No registered users viewing this page.

×