Welcome to SSA Car Audio Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Followers 0
Liro213

What's going on with fi?

22 posts in this topic

I sent out 2 emails with no replies. I'm Just wondering what happened with the "customer support"?

I received 1 of 2 ssd with wrong fi color. My question was could you send out a free black "fi" sticker to replace with the right color, with out sending the subwoofer back?

I know it's such a small thing but when you wait 2 weeks and pay 500$ , you should expect everything to be 10/10. I did mount my subs already as I became impatient over time. Well anyway hope to hear back , thanks..

I don't know how to post pics..

1

Share this post


Link to post
Share on other sites

Warning: Cannot modify header information - headers already sent by (output started at /home/soundsol/public_html/forum/ips_kernel/classAjax.php:1) in /home/soundsol/public_html/forum/ips_kernel/classAjax.php on line 323

Warning: Cannot modify header information - headers already sent by (output started at /home/soundsol/public_html/forum/ips_kernel/classAjax.php:1) in /home/soundsol/public_html/forum/ips_kernel/classAjax.php on line 326

Warning: Cannot modify header information - headers already sent by (output started at /home/soundsol/public_html/forum/ips_kernel/classAjax.php:1) in /home/soundsol/public_html/forum/ips_kernel/classAjax.php on line 327

Warning: Cannot modify header information - headers already sent by (output started at /home/soundsol/public_html/forum/ips_kernel/classAjax.php:1) in /home/soundsol/public_html/forum/ips_kernel/classAjax.php on line 328

 

I sent out 2 emails with no replies. I'm Just wondering what happened with the "customer support"?

I received 1 of 2 ssd with wrong fi color. My question was could you send out a free black "fi" sticker to replace with the right color, with out sending the subwoofer back?

I know it's such a small thing but when you wait 2 weeks and pay 500$ , you should expect everything to be 10/10. I did mount my subs already as I became impatient over time. Well anyway hope to hear back , thanks..

I don't know how to post pics..

Upload them to www.imgur.com and use the link.

0

Share this post


Link to post
Share on other sites

Thanks.. I have the images uploaded. Do I just send the link over? Or which one do I use to post the pics?

0

Share this post


Link to post
Share on other sites

What date did you send e-mails? I know some of the guys were out from Thursday and not back in till tomorrow.

 

Won't be an issue to get a sticker sent out, I'll speak with Scott tomorrow for you.

0

Share this post


Link to post
Share on other sites

I believe I emailed that very same day I took the pictures , 2/5/16 .. I Don't have direct contact so I really appreciate it sir.

0

Share this post


Link to post
Share on other sites

I know they are in manic catch up mode as some coils showed up a little late and they are working to catch up.

1

Share this post


Link to post
Share on other sites

I believe I emailed that very same day I took the pictures , 2/5/16 .. I Don't have direct contact so I really appreciate it sir.

 

Can you send me your order number and I'll have someone look into it.

0

Share this post


Link to post
Share on other sites

Biltd pmed you.

Aaron thanks, I would've thought they would of replied by now but still no word from anyone but you guys..

1

Share this post


Link to post
Share on other sites

No word from fi .

0

Share this post


Link to post
Share on other sites

I'm wondering the same thing, I was emailing nick over the summer about a sub that didn't sound right, and he was responding until i asked to send it back.  After no response for months I emailed again in january asking for an RMA, again in the middle of feb, and then again today since my warranty expires tomorrow. I also cant log into the fi website ever since they redesigned it, it says my account doesnt exist??

1

Share this post


Link to post
Share on other sites
20 minutes ago, bluelaser said:

I'm wondering the same thing, I was emailing nick over the summer about a sub that didn't sound right, and he was responding until i asked to send it back.  After no response for months I emailed again in january asking for an RMA, again in the middle of feb, and then again today since my warranty expires tomorrow. I also cant log into the fi website ever since they redesigned it, it says my account doesnt exist??

Nick no longer works there, I would try emailing them at sales@ficaraudio.com.

The website I believe is different software since their update, so I would imagine their user accounts didn't get converted over, hence why it thinks you don't have an account.

**These are just assumptions, based on my web knowledge, and I do NOT work for Fi.

1

Share this post


Link to post
Share on other sites

I have always emailed sales@ficaraudio.com, he was just the guy that would always respond. haven't gotten a response in over 6 months now

0

Share this post


Link to post
Share on other sites

Biltd helped me out. He spoke with them directly for me.. yet I don't have a confirmation that my decals have been sent. I'll just have to wait for now..

That sucks man , you waited too long? Did you continue to use the sub that way? 

0

Share this post


Link to post
Share on other sites

6 months and no response? My guess is emails simply not reaching there Inbox.

Anyone who ordered off the old store will not have there account details transferred to the new store, since they run on different software.

@Liro213, your stickers are in the post. Should be be with you momentarily.

@bluelaser, if you can resend your e-mail to sales@ficaraudio.com via a different email then that should work.

If you guys have no joy holla at me and I'll get Scott on it ;)
 

1

Share this post


Link to post
Share on other sites

Ok I received the stickers (2) today. Like I said biltd helped a bunch. 

Biltd pm'd you about Another problem :mellow:

http://imgur.com/a/9VrF4

0

Share this post


Link to post
Share on other sites

I dont mean to thread jack or be "that guy", but it seems  biltd has  the ins with Fi lol do any of you know an approximate time before recieving a sub that was ordered? 1 week? 2 weeks? 3 weeks? Awaiting for the arrival of my sp4,but im sure im not the only one who was dying of excitement and the anticipation of receiving it, is killing me slowly lol

Edited by Rx7teecolon
0

Share this post


Link to post
Share on other sites
5 hours ago, Rx7teecolon said:

I dont mean to thread jack or be "that guy", but it seems  biltd has  the ins with Fi lol do any of you know an approximate time before recieving a sub that was ordered? 1 week? 2 weeks? 3 weeks? Awaiting for the arrival of my sp4,but im sure im not the only one who was dying of excitement and the anticipation of receiving it, is killing me slowly lol

Yeah waiting is the momentum build up  and once ordered its only a matter of time :D my waiting time wasn't as bad for my ssd's. 

0

Share this post


Link to post
Share on other sites

Well no replies from anyone.

only thing that helped was pull the leads outwards away from cone and spider. Noise is less noticeable. If I would've known, I would have chose the internal lead option. Just for anyone considering buying an ssd..

Otherwise they have been doing well, and surely make me smile every now and then. They blend when you want, and get crazy when u want. Thanks Fi but your customer support needs work..

image.thumb.jpeg.fd7d7f49a7c740c02b917b5

0

Share this post


Link to post
Share on other sites

I love Fi even though it's hard to get through to them, and SSA for always being here to help!

2

Share this post


Link to post
Share on other sites

Hey guys.

Scott and the guys at Fi are pretty stretched when it comes to getting on the forums these days. Yes I cover all European operations for Fi Car Audio and Ascendant Audio. Doesn't necessarily mean I deal with US domestic sales or after sales. But I help out where I can.

@Liro213 the initial rub marks made me wonder if your subsonic filter is set correctly. 2-3Hz below the tuning frequency of your enclosure. Otherwise I would try to slightly pull the lead up where the curve is so the tinsel lead is following the cone more. Sometimes a little push or bend on the solidered tab with the pull can change the posture enough to prevent slap in the future.

@Rx7teecolon Build times are usually stated on the site at the time of your order. If there are parts shortage or delays that can extend completion of your order, but not by a huge amount. Couple days or a week usually.

0

Share this post


Link to post
Share on other sites

So biltd has the ins? Ive been trying to reach them too and my emails are returned and im told inbox is full? I want to order a new sp4v2 18 but not being able to get ahold of anybody has me wondering if im going to head another route

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Who's Online   0 Members, 0 Anonymous, 23 Guests (See full list)

    There are no registered users currently online

  • Recently Browsing

    No registered users viewing this page.