Jump to content
jcarter1885

2015 Hyundai Sonata Sport/Limited

Recommended Posts

Northstar 31s are sold out earlier so I just got the equivalence at the same cost, so win win. Even though I have OCD it wont bother me that bad. 

 

20201113_191109.jpg

20201113_191414.jpg

20201113_193000.jpg

20201113_193029.jpg

Share this post


Link to post
Share on other sites
On 10/29/2020 at 5:37 PM, jcarter1885 said:

Thanks guys, I love your product. I left a review but for some reason couldn't upload pictures at the time.

If you send us the pictures we can give them to TrustSpot and they can add them in. Sometimes the follow-up page doesn't pop up after the review is submitted to add pictures, it is a 2 step process. You can also submit them through the Trust Spot link on the site under Customer Projects. 

Share this post


Link to post
Share on other sites

Finally ran the right size power wire for the starting battery to fuse distribution block. Cut some plastic off the factory power block terminal and got the 2/o welding cable terminal installed. Upgraded the fuse from an 80a ANL to a 350a ANL fuse. Trunk will be rewired for subwoofer install tomorrow morning. Its been too long without bass. I wont hammer on it for awhile since my car has a smart charging feature that doesnt allow it to see full voltage at all times. H/O Alt is being looked into at the moment.

20200603_115939.jpg

20201121_173027.jpg

20201121_173039.jpg

Share this post


Link to post
Share on other sites

After almost 3 years she is playing finally. Don't enjoy the sub amplifier on the dsp so far. Every forum says to leave the crossovers wide open on the Amere 3800 amp since there is no full pass or way to turn of the lpf on the amplifier. While leaving the crossovers wide open and tuning with the dsp its not allowing the sub to get moving. Turned crossovers down to halfway point on the amp definitely woke up the subwoofer a lot though. 

 

I have the sub set at lpf 65hz at 24db and ssf 28hz @ 24db on the dsp for now. Subwoofer is a Fi Sp4 dual 2 wired to 1 ohm on a Ampere Audio AA3800.1. 

Share this post


Link to post
Share on other sites

After years and years and years of salivating over these things, I finally have my HLCDs. Im so excited, dont know when Ill try to mount these things. I honestly didn't think the horn body was this massive.

20201215_202351.jpg

20201215_200846.jpg

20201215_200814.jpg

20201215_200825.jpg

Share this post


Link to post
Share on other sites

Time to get my car detailed on the inside since these new mats will be going in. 

20201216_165702_HDR.jpg

Share this post


Link to post
Share on other sites

Good luck with the horns Justin! 

Share this post


Link to post
Share on other sites
On 12/19/2020 at 8:30 AM, Tirefryr said:

Good luck with the horns Justin! 

I definitely appreciate ya man, Im anxious to get started. 

Share this post


Link to post
Share on other sites

Slowly getting these Weather Tech mats installed, backseats done so far.20201221_172112.thumb.jpg.12baf7d4da1dd84be0dab99108769944.jpg

20201221_172121.jpg

Share this post


Link to post
Share on other sites

I had some down time and 60 degree weather to get some stuff done to the ride. I replaced a panel that I broke out of frustration while looking for a screw when installing my radio last year. Dont mind the floor mats didnt clean them out before pictures were taken. 

20210106_134018.jpg

20210106_134024.jpg

20210117_111430.jpg

Share this post


Link to post
Share on other sites

My factory USB outlet was always an issue when I first received the car and looking into Hyundai Forums, I wasnt the only one with this issue so I had to fix it. When I first installed my radio I did temp install with usb extension cord that came with my Pioneer radio. In the first picture in between my leg and gear shifter, there is the USB cord just laying there loosely. This time I did a permanent install, removed the factory connection and ran a 3.0 USB cable through the factory opening. 

20200502_125618.jpg

20210117_102731.jpg

20210117_102733.jpg

20210117_102744.jpg

20210117_103035.jpg

20210117_103041.jpg

20210117_104234.jpg

20210117_104240.jpg

20210117_111430.jpg

20210117_123409.jpg

20210117_123512.jpg

20210117_124119.jpg

20210117_124512_HDR.jpg

Edited by jcarter1885
Pictures

Share this post


Link to post
Share on other sites

Jims Machine Worx does some bad ass machine work, this 4 Input and Output 1/0 Fuse Distribution Block is dope. I will attach this to my battery box in my trunk for a cleaner wiring job. 

20210118_214015.jpg

20210118_214019.jpg

20210118_214340.jpg

20210118_214337.jpg

20210118_214323.jpg

20210118_214114.jpg

20210118_214315.jpg

20210118_214059.jpg

20210118_214046_HDR.jpg

20210118_214038.jpg

Edited by jcarter1885

Share this post


Link to post
Share on other sites

Decided to clean my trunk and wiring up some, bought a new amp board since ill be removing my amp from being mounted to the enclosure.  I like the shorter board, makes it almost look like its floating. 

20210120_073006.jpg

20210120_073032.jpg

20210120_073040.jpg

Share this post


Link to post
Share on other sites

New DSP alert, Dayton will be gone once I receive two pairs of RCAs from NVX. The Dayton was nice and I learned a lot just couldn't get rid of the white noise no matter what. I have changed all my grounds, reran RCAs etc. Spent days of wiring and unwiring with no end it sight, after my third one from Dayton. First one had other issues besides the white noise as well. 

20210120_154514.jpg

20210120_154557.jpg

20210120_154622.jpg

20210120_154627.jpg

20210120_154633.jpg

20210120_154714.jpg

20210120_154725.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×