Jump to content

Recommended Posts

Funny, I've almost a few times.  I have some untrackable noise in my truck right now and thought about it.

Share this post


Link to post
Share on other sites

The price is hard to not consider.  Shame it doesn't have 6 in.  It is surprising in some ways, as many of the people who buy DSPs are one who care about the little bits being the nicest thing, once such thing being tiffany RCA jacks, yet most DSPs have the cheapest aluminum rca jacks.

Share this post


Link to post
Share on other sites

wow nice find! 

Share this post


Link to post
Share on other sites

I wish these were out before I bought my Stetsom DSP.  I like the Stetsom, it meets my needs, but shipping took forever and the plastic body feels a little cheap, not to mention the Dayton is $50 less.

Share this post


Link to post
Share on other sites
On 9/24/2018 at 11:59 AM, SS Teacher said:

I wish these were out before I bought my Stetsom DSP.  I like the Stetsom, it meets my needs, but shipping took forever and the plastic body feels a little cheap, not to mention the Dayton is $50 less.

Maybe sell it for the same price as the Dayton and break even??

Share this post


Link to post
Share on other sites

I might have to break down and try one, seems like a nice deal. Other units im looking at are the JL TWK88 or DD DSI-2

Share this post


Link to post
Share on other sites
On 7/21/2018 at 6:44 AM, ///M5 said:

Funny, I've almost a few times.  I have some untrackable noise in my truck right now and thought about it.

If your “under the hood” is similar to mine, there is a “ground sensor” near the battery. I was told to work around it and not change anything. May be something to look into.

 

Share this post


Link to post
Share on other sites
On 9/29/2018 at 8:10 AM, Aaron Clinton said:

Maybe sell it for the same price as the Dayton and break even??

The Stetsom is TINY and if fits my needs.  Plus, i tend to horde car audio :)

Share this post


Link to post
Share on other sites
On 9/29/2018 at 6:56 PM, Randal Johnson said:

If your “under the hood” is similar to mine, there is a “ground sensor” near the battery. I was told to work around it and not change anything. May be something to look into.

 

Thanks.  Was a bad relay, but didn't sound like a normal relay going bad.  Aargh.  

Share this post


Link to post
Share on other sites
On ‎10‎/‎25‎/‎2018 at 8:31 AM, ///M5 said:

Thanks.  Was a bad relay, but didn't sound like a normal relay going bad.  Aargh.  

Dang. Glad you found it !!!

Was it a factory integrated relay or aftermarket installed audio system relay ??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×