Jump to content

Recommended Posts

The number bug as bitten.

Share this post


Link to post
Share on other sites
6 hours ago, Aaron Clinton said:

The number bug as bitten.

Haha yes it but I won't get too crazy. One thing I do know if I ever go back to two 12s then you know the deal :rockwoot:

Share this post


Link to post
Share on other sites

Inside wire hole is now sealed, letting it all cure for a few days. 

 

There's a show at Crossfire Car Audio on Saturday, I doubt I'll make it though but we will see.

20220316_212747.jpg

20220316_212718.jpg

20220316_212810.jpg

Share this post


Link to post
Share on other sites

ALways gotta let  the hole cure.   Nice and tight!

Share this post


Link to post
Share on other sites
5 hours ago, Tirefryr said:

ALways gotta let  the hole cure.   Nice and tight!

Yes sir, no point on rushing it all. I also added some wire tie down clamps and covered them in amazing goop as well. Wires were ziptied together as well. I love amazing goop.

20220319_192120.jpg

20220319_192129.jpg

20220319_193136.jpg

Share this post


Link to post
Share on other sites
Posted (edited)

Good news and bad news, I'm glad I decided to work on my trunk wiring with the enclosure out because I found this. Any input on why or what happened? Fuse wasnt burned or blown but some discoloration. I also cant get the terminal unscrewed to remove the wire.

 

Upgrading subwoofer amplifier power/ground wires to 2/0 welding cable as well. Only car audio wire will be speaker wire and power/ground wire for front stage amplifier for now.

20220320_191558.jpg

20220320_191616.jpg

Edited by jcarter1885

Share this post


Link to post
Share on other sites

Going to change a lot of things. That fuse holder will be coming out and I will be getting an SMD Fuse holder and will crimp all wires to prevent this from happening in the future. I'm also trying to upgrade amps to a Crossfire 4K so this may delay the box going in for a while. H/O Alternator is in the works too, trying to stop buying car audio this year. 

Share this post


Link to post
Share on other sites

That's definitely a loose connection issue.  Under high current, this will generate a lot of heat and you'll  get what you see here.   I've seen DC motors weld cable to terminals with as little as 30 amps.   It happens before you know it too.

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, Tirefryr said:

That's definitely a loose connection issue.  Under high current, this will generate a lot of heat and you'll  get what you see here.   I've seen DC motors weld cable to terminals with as little as 30 amps.   It happens before you know it too.

Thanks I greatly appreciate it because I never seen this before and it had me worried. I'm glad I caught it when I did. 

 

I will buy a crimper and will be crimping all my wire from here on out. No more set screw style fuse blocks from here out either. Not blaming them but if this can be avoided by not going that route then I'm all for it.

Edited by jcarter1885

Share this post


Link to post
Share on other sites
Posted (edited)

Got a little work done before this storm and tornado warning came through after work, shortened my ground wires coming from the trunk spare well going to battery terminal a lot. Instead of going around the back of battery, above it and back down the front of it. The wires come straight up to the terminal. I also cut the ground wire for my Audio Control amp as well and wired that on that last connection underneath the negative battery terminal. The only ground wire that will be attached on the topside of the negative battery terminal will be for the subwoofer amplifier. I should of done this months ago but I hate working on the car in the cold. There will be no ground wires coming across the top of the battery box. Looks so much better already and I'm no where near finished. 

Before picture first and after pictures will follow.

 

20211228_120737.jpg

20220321_181401.jpg

20220321_181408.jpg

20220321_205537.jpg

20220321_205550.jpg

20220321_205556.jpg

Edited by jcarter1885

Share this post


Link to post
Share on other sites
Posted (edited)

Don't worry, no subwoofers were hurt during transport. Sheesh when your tweeter is bigger than your subwoofer.

20220322_164249.jpg

20220322_164254.jpg

20220322_164451.jpg

Edited by jcarter1885

Share this post


Link to post
Share on other sites

I had to do a lineup photo since the box wasn't in the trunk.

20220322_172108.jpg

20220322_172054.jpg

20220322_172104.jpg

20220322_172031.jpg

Share this post


Link to post
Share on other sites

So for the first time in forever I fucked up, but it's ok y'all can flame me. I was rushing and excited, I also tried new screws but at the end of the day it was all my fault. Little drill slippage that I fixed with amazing good, put it on the underside and top of surround as well. Luckily it dries clear and the location of the hole in the surround when the sub is mounted, is at the back of the box so you cant see it anyway.  

 

Like Dae Dae said in next Friday, Playas Fuck Up!   Haha

 

IMG_9487.jpg

670082862.jpg

Share this post


Link to post
Share on other sites

This enclosure turned out perfect, I cant wait till night time and I turn on the blue light to see how it all plays out.

20220327_170432.jpg

20220327_170440.jpg

20220327_170450.jpg

20220327_170455.jpg

20220327_170500.jpg

20220327_170503.jpg

20220327_170631.jpg

20220327_170703.jpg

20220327_170719.jpg

20220327_170722.jpg

Share this post


Link to post
Share on other sites
Posted (edited)

It all started with a vision, then once it's executed you realize that it's way more dope in person.

 

20220327_200720.jpg

20220327_200724.jpg

20220327_200755.jpg

20220327_200759.jpg

20220327_200807.jpg

20220327_200815.jpg

20220327_200820.jpg

20220327_200852.jpg

20220327_200900.jpg

20220327_200905.jpg

20220327_200911.jpg

20220327_200928.jpg

Edited by jcarter1885

Share this post


Link to post
Share on other sites

New high score even with lower voltage since it's warmer outside and my car charges at a lower voltage depending on the heat.

20220328_081916.jpg

Share this post


Link to post
Share on other sites

20220327_213425.jpg

20220327_213430.jpg

Share this post


Link to post
Share on other sites

Just went through this whole build for ideas…

 

awesome work man!

Share this post


Link to post
Share on other sites

I finally got around to adding some dielectric grease to the front battery terminals. I also added my power wire for my alternator and I should be ordering my H/O Alternator here soon.

 

 

20220402_122227.jpg

20220402_130002.jpg

Share this post


Link to post
Share on other sites
45 minutes ago, mrray13 said:

Just went through this whole build for ideas…

 

awesome work man!

Thank you very much I appreciate it, stick around as there are more things to come and I'll be addressing some things I should of executed better. 

Share this post


Link to post
Share on other sites

DAMN!  

 

Is that Duratex  on the box?

Share this post


Link to post
Share on other sites
Posted (edited)

Updates

I'm still waiting on Stevens Audio MB-8 2ohm mids to get back in stock then I will send the car to the shop to have them fabricate my Sony 8" H/U in my dash and do my front doors with one pair of 8s in each door.

 

Will be ordering SMD Fuse blocks for under hood positive wires and trunk's positive wires. All connections will be crimped with terminals. 

 

I have quotes from Stinger and Brand X for H/O Alternators, just trying to do research to see who to go with. Ive noticed voltage issues from factory as the weather gets warmer and have been following Euro Bass Girl and she gave me some ideas to mitigate that problem. I ordered a voltage regulator controller knob from Conventry Industries that I will install when the new alternator gets here.

 

20220322_152739.jpg

20220322_152752.jpg

20220322_152918.jpg

20220322_152937.jpg

Edited by jcarter1885

Share this post


Link to post
Share on other sites
Posted (edited)
15 minutes ago, Tirefryr said:

DAMN!  

 

Is that Duratex  on the box?

Yes sir it is, now I'm upset my battery box doesn't match the enclosure. I will be getting photos tonight with the enclosure's led lights playing. 

Edited by jcarter1885

Share this post


Link to post
Share on other sites

did you have any issues with it cracking/shrinking?  I had a hell of a time with that.

Share this post


Link to post
Share on other sites
1 hour ago, Tirefryr said:

did you have any issues with it cracking/shrinking?  I had a hell of a time with that.

I didn't apply it my box builder did, but from looking at it. It doesn't seem like he had issues nor did he mention any. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×