Jump to content
Sign in to follow this  
aznegg

SSA Xcon purchase 3/30/13 - receive 5-31-13 - broke 7-20-13 - promise

Recommended Posts

As title says,

 

Purchased product - march 30th 2013 (approx)

 

Product received - may 31st 2013 (approx 2 month wait.. no big deal gonna be awesome right)

 

Product self destruct - cone broke outwards 7-20-13 (powered by rf t1500.1, yellow top battery, plenty of breaking, cone broke outward not inward, and had a grill  stepped off the box (after my gfs RE SX got a  hockey skate through it i will never do a naked install again)

 

Contacted company July 27th to inform them of the issue, simple dust cap replacement, no big deal they promised me to ship it out asap.

 

 

July 27 -> now 

 

4 separate back and forths, all with promises that it will be shipped out immediately. No tracking number is ever sent.

 

Ive held my tongue for 5 1/2 months, i really dont like talking shit about a company, especially one that produced something i enjoyed so much for a month and a half. But i need to get this back in my car and working again, its unacceptable to have a customer shafted for 5 1/2 months..... At this point i dont know what to do anymore, i hope an admin sees this and can somehow work it out, but im not sure what he will be able to do.

 

 

Just my experience,  i will not give out the name of the person i have been corresponding with (Except to ssa staff). As things may really have been out of his control... regardless of how naive that sounds, i really hope ssa can pull it together and make this right, i truly love the product and fully endorse the sound. But i feel scared and bitter about this interaction with the company itself.

 

 

thanks. 

Share this post


Link to post
Share on other sites

Any pictures of the sub? What enclosure was it in and where were all of the settings on the amp set at?

Share this post


Link to post
Share on other sites

And you can remove the dust cap and continue to use it if that helps at all.

Share this post


Link to post
Share on other sites

sub move both ways so please show and explain how your sub " self destructed "

Share this post


Link to post
Share on other sites

Did you purchase directly from SSA or from a dealer?

Share this post


Link to post
Share on other sites

I am looking into this right now.  If a part we requested was supposed to shipped from the build house, I will have to call again.

Share this post


Link to post
Share on other sites

Found it, creating another new build ticket, ... fixed

Edited by Aaron Clinton

Share this post


Link to post
Share on other sites

Your new order for the replacement cap has been created and already fulfilled.  Cap is shipping today VIA USPS: LZ 316 811 954 US.

Share this post


Link to post
Share on other sites

I would have taken pictures before disassembling sub had I been asked, the subwoofer dust cap most likely had a small defect which pushed outward. The grill in question had more than. Enough Xmas room, it was stepped off the box with an 1" mdf ring (sub is mounted below flush with front of box. Easily clearing 2" of clearance. Plus my trunk was empty.

In any case this has been resolved. And tbh I'll just be happy yo have my sub back. Its by farthe best sub I've ever had.... Xxx, fiq, w7, sx, idmax, etc etc this thing annihilates them all.

Share this post


Link to post
Share on other sites

Side not the box was designed by pwkdesigns (hexibase on YouTube) and was professionally built from a local audio shop

Share this post


Link to post
Share on other sites

SSA slamming solutions !!!

Share this post


Link to post
Share on other sites

OP you had very bad luck with this.

SSA customer service is top notch. they answer emails even on sundays !
 

When I need a caraudio product for anyone, I start to look at the ssa store first :)  :)

 

enjoy your xcon : this sub is marvelous !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

    1. Recent Topics

        • 212 comments
        • 18,298 views
        • 1 comment
        • 9 views
        • 5 comments
        • 212 views
        • 3 comments
        • 76 views
        • 28 comments
        • 2,269 views
        • 4 comments
        • 113 views
  • Similar Content

    • By Dexter Chaos
      I have 2 SSA zcons 12's D1
      These subs are absolutely amazing.
      As stated in title
      1 is working
      1 is not, burn mark in spider appears to be tinsel
      $450 + shipping for both



    • By Sencheezy
      I just finished installing my SSA Carbon Fiber Convex Dust Cap and I am really impressed by the way it looks. I have not taking a listen yet, though I'm sure there won't be any audibel difference. Here are a few photos I have taken.
      Here is a overview of both caps side by side

      Here you can that the original cap is "taller". Not exactly sure how this will affect anything.

      In this picture, it is very hard to see, but I place the new cap over on top of the other, to show that the new cap's "flanged" is just a hair bit longer.

      In this photo, you can see some bubbles in the crease around the cap before the flange begins.

      In this photo, pretty hard to see, but really really close up, you can see these "scratches"? I'm not exactly sure where this is from lol. But you have to be really close to see.

      In this photo, you can see all of its sexyness

      In this photo, you can see one of the problems I ran into. When removing the original cap, whats left is the glue's residue? I'm not sure what to call it, but it leaves two O-type rings around the former. When trying to lay down the New cap, it would not sit flat or flush. So I was forced to chip away with a small flat head screw driver on the outer ring. The inner ring seems a bit more permanent.

      Here is the epoxy I just picket up from Lowe's. Seems to work really well. It got real stinky real fast.

      In this photo, you can see the outter ring chiped away.

      And here is it installed

      I got a bit messy This was my first time every doing this, but atleast its clear, so it doesn't look too too bad. Cosmetically though, this looks aMAZEing. Also, I will note that the cap I recieved, did not flush with the cone. It seems that the cone, and the flang are formed at two different angles. Not too too much difference, but enough to not look flush. So I had to use a little bit more glue, and push down as much as I could to try and make sure there is no gaps in between the connection of the cap and the cone.
      The original cone does seem a bit more "solid" for the lack of term. Like, the original cap is a hard plastic, you could knock on the back of the cap, and it would make a decent "thund". But the new cap, like, I could push it in? If that makes sense. I've never personally handled Carbon Fiber, so I don't know what to expect. Maybe bend but never break kind of thing? lol. It is extremely light though!

      So overall, I am pleased with this product and would definately purchase more in the future. Thank you very much SSA and Duran for allowing to me purchase another amazing top notch quality item
    • By luckyycharmzz13@yahoo.com
      i have had 2 10" ssd for almost 2 weeks and the duscap one one of the subs has come unglued. Has anyone else had this problem? i know i could just re glue it but this shouldnt happen after 2 weeks and i havent been beating on them either, i emailed fi but anyone else have any suggestions, i know about CA glue but im not sure what i should do, any help would be great. Thanks
  • Recent YouTube Posts

×