Jump to content
frogcase2002

05 sable 2 zcon 18s on 10k in b-pillar walll

Recommended Posts

33 minutes ago, Infinite913 said:

Well did they fit?

Nope only goes up to 1/0 . . Mite just have to use a fat screwdriver and a hammer To crimp the 4/0 lol  . . Or could try soldering . Have never soldered any copper lugs befor

Share this post


Link to post
Share on other sites

Fit on my hammer crimper :)

1507654597403.jpg

Share this post


Link to post
Share on other sites

Baffle just sittin there. Just to give you an idea of what it will look like

1507656566736.jpg

Share this post


Link to post
Share on other sites

Test fitting pieces

1507660297022.jpg

Share this post


Link to post
Share on other sites

1507849907699.jpg

Share this post


Link to post
Share on other sites

Man its coming together. Im getting excited lol

1507854079619.jpg

Share this post


Link to post
Share on other sites

I'm excited just watching! Its gonna be head crackin'!! :)

Share this post


Link to post
Share on other sites

Been without audio for over a year . Not even a head unit lol

Share this post


Link to post
Share on other sites

Pretty much just some finberglassing to do :)

sucks i dont have tweeters yet . Mite have just just pick up a couple for a few bucks at parts express just to hold me off untill i get the ssa tweeters

Share this post


Link to post
Share on other sites

Ouch that's a long time without tunes dude.

loOks like you getting close! Almost time to start hooking up equipment!! :)

Share this post


Link to post
Share on other sites

I know . Hope to have the subs in within a week . . Still got to run all my 4/0 and run new speaker wires for mids and highs

Share this post


Link to post
Share on other sites

Looks great man. I'm jelly...

Share this post


Link to post
Share on other sites

2 runs pos 1 run neg of 4/0 . For now

1507934090380.jpg

1507934130199.jpg

Share this post


Link to post
Share on other sites

1507939652201.jpg

Share this post


Link to post
Share on other sites

Fiberglassing tomorrow! 

Share this post


Link to post
Share on other sites

Need to figure out about my alt to . I want to try to use my 300 amp I had in the van but it a little different than the stock sable one but I think ill be able to fit it with some spacers . . Only thing is that the plug on the alt is 2 wires and the sable has 3 . I think one is just for the batt light on the dash so I wouldnt need that one ran . So need to figure out how to wire it up . 

I do have one of them blue voltage regulators layin around at the shop so maybe there is a way were I wouldnt even need to wire the alt in to the sable alt plug. I dont know. Need to figure something out soon . . Really dont wanna buy another $500+ alt when my old one was only used like a month befor the van broke and I can get it to fit in the sable

Share this post


Link to post
Share on other sites
18 hours ago, Travis said:

Looks great man. I'm jelly...

Thanks Man .  Mite get to hear It sometime . Im In ohio to

Share this post


Link to post
Share on other sites

The extra wire on the alternator most likely is a feed from the (more advanced) computer.  The other two are field and stator wires.  The one I did required a 47 ohm resistor on the extra wire... then I believe it was hooked to the power wire. Would need to confirm all that to make for sure.  Is to tell the alternator to charge. Iirc the resister stepped it down to 5 V,  same as the computer would send to it.

Share this post


Link to post
Share on other sites
10 hours ago, frogcase2002 said:

2 runs pos 1 run neg of 4/0 . For now

1507934090380.jpg

1507934130199.jpg

I love the zip ties keeping it clean. Only suggestion I would make is maybe securing the wires under the car or through the car. :lol:!!! Looking great so far man keep it up!

Share this post


Link to post
Share on other sites

Nice progress!!  I feel ya on the tunes...been without any since june myself.

Share this post


Link to post
Share on other sites
5 hours ago, Infinite913 said:

I love the zip ties keeping it Only suggestion I would make is maybe securing the wires under the car or through the car. :lol:!!! Looking great so far man keep it up!

I ran them Inside the plastic panel that runs along the rocker panel .  

Share this post


Link to post
Share on other sites

Not perfect but it will get the job done

1508002653050.jpg

1508002690758.jpg

Share this post


Link to post
Share on other sites

1508011334150.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing

×