Jump to content
ManzKea

Ssa evil 12s finally arrived

Recommended Posts

Notorious97200    305

I can't see those pics.

"Please update your account..." : that's the photobucket message I can read. Like on all my pics in my build log.

Share this post


Link to post
Share on other sites
ManzKea    37

Lol it was working earlier. What do I have to do 

Share this post


Link to post
Share on other sites
jcarter1885    690

Pay for their services or find another site to host your photos.

Share this post


Link to post
Share on other sites
ManzKea    37

What the heck. Thought it was free.  Crazy now days 

Share this post


Link to post
Share on other sites
jcarter1885    690

Yeah they recently just started that. Sucks

Share this post


Link to post
Share on other sites
ManzKea    37

Well anyways I like the sound of the subs but not entirely in love with it. So I'm gonna make another box. This time with the slot on the passenger side firing back. And it'll keep the tuning of 32 because after I chopped off that 3.5" I'm guessing the tuning went up. Still gonna keep it subs up port back.  I like it like this, makes it so convenient to remove the subs . I do know I'm losing a lot of output being in a removable hardtop Jeep Wrangler. But it gets loud and sounds great from the outside. So can't wit to see if this new box will make a noticible difference. Probably start it this weekend 

Share this post


Link to post
Share on other sites
ManzKea    37

<a href="http://s1294.photobucket.com/user/808kea808/media/ssa%20evil/A1D1DE60-53FD-4B84-9381-C1A6305635C0_zpsaqy27tg9.jpg.html" target="_blank"><img src="http://i1294.photobucket.com/albums/b613/808kea808/ssa%20evil/A1D1DE60-53FD-4B84-9381-C1A6305635C0_zpsaqy27tg9.jpg" border="0" alt=" photo A1D1DE60-53FD-4B84-9381-C1A6305635C0_zpsaqy27tg9.jpg"></a>

 

Did the link to the pic show ?

Share this post


Link to post
Share on other sites
ManzKea    37

Well there it is maybe y'all can click it to go to the album in my Photobucket and look through the pics

Share this post


Link to post
Share on other sites
ManzKea    37

Sweet. Can we just directly upload the pics from the reply box?

Share this post


Link to post
Share on other sites
Travis    42

I could when I first joined but it didn't last long

Share this post


Link to post
Share on other sites
ManzKea    37

Ok. We'll see how long this last 

Share this post


Link to post
Share on other sites
ManzKea    37

Some video of the evils in action. 

 

 

 

let me know what y'all think. Impressive, ok, or nah? Lol. 

Share this post


Link to post
Share on other sites
jcarter1885    690

Have you tried changing the box orientation, maybe subs facing the rear instead of up?

Share this post


Link to post
Share on other sites
ManzKea    37

No I haven't done that yet. If I did that the port would be firing up. I usually put sub and port on the same side but I read somewhere that sub up port back works well in an SUV. So I tried it

Share this post


Link to post
Share on other sites
Travis    42

I'd say pretty decent. Nice job man

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing

    No registered users viewing this page.

×